Updates have been released for Drupal versions 8.9, 9.0 and 9.1. Drupal is a PHP-written, user-friendly and powerful content management platform, with which, for example, websites can be created. It’s simple enough for a novice user, but powerful enough to build a more complex website as well. The program includes a content management platform and a development framework. The updates contain a fix for a cross-site scripting vulnerability:
Drupal core – Moderately critical – Cross Site Scripting – SA-CORE-2021-003
Project: Drupal core
Security risk: Moderately critical 14∕25 AC:Basic/A:User/CI:Some/II:Some/E:Proof/TD:Default
Vulnerability: Cross Site Scripting
Description: Drupal core uses the third-party CKEditor library. This library has an error in parsing HTML that could lead to an XSS attack. CKEditor 4.16.1 and later include the fix.
Users of the CKEditor library via means other than Drupal core should update their 3rd party code (eg the WYSIWYG module for Drupal 7). The Drupal Security Team policy is not to alert for issues affecting 3rd party libraries unless those are shipped with Drupal core. See DRUPAL-SA-PSA-2016-004 for more details .
This issue is mitigated by the fact that it only affects sites with CKEditor enabled.
Solution: Install the latest version:
- If you are using Drupal 9.1, update to Drupal 9.1.9 .
- If you are using Drupal 9.0, update to Drupal 9.0.14 .
- If you are using Drupal 8.9, update to Drupal 8.9.16 .
Versions of Drupal 8 prior to 8.9.x are end-of-life and do not receive security coverage.
|Version number||8.9.16/9.0.14 / 9.1.9|
|Operating systems||script language|