Software Update: Engarde Secure Linux 3.0.20

Engarde Secure Linux is a Linux distribution aimed at servers that need a high level of security. It contains a number of standard applications with which various server tasks can be performed without problems, such as serving dynamic websites, mail and performing network intrusion detection. For more information, we refer you to this page† Version 3.0.20 has recently become available and has the following announcement text:

Guardian Digital is happy to announce the release of EnGarde Secure Community 3.0.20 (Version 3.0, Release 20). This release includes many updated packages and bug fixes and some feature enhancements to the EnGarde Secure Linux Installer and the SELinux policy.

The following reported bugs from bugs.engardelinux.org are fixed in this release:

  • #0000175 CSS
  • #0000189 Installer thinks disk is read only
  • #0000193 Does not install
  • #0000194 After doing update to 3.0.19 via web interface I got two …
  • #0000195 After upgrading to 3.0.19 I get error in package selection…
  • #0000196 DCHP package fails to start after update
  • #0000197 Drivers for AMD 690G
  • #0000198 Domain keys
  • #0000199 Typo in apache.pm

Several other bugs are fixed in this release as well.

New features include:

  • Several new packages such as cups (1.3.7), lockdev (1.0.1), minicom (2.3), perl-Crypt-OpenSSL-Bignum (0.04), perl-Crypt-OpenSSL-RSA (0.25), perl-Crypt- OpenSSL-Random (0.04), perl-Digest-SHA (5.47), and perl-Mail-DKIM (0.32).
  • The latest stable versions of ImageMagick (6.4.2), MySQL (5.0.51b), alpine (1.10), amanda (2.6.0p1), apache (2.2.9), aspell (0.60.6), asterisk (1.4.21.1 ), bacula (2.4.1), bind (9.4.2-P1), clamav (0.93.3), curl (7.18.2), dovecot (1.1.1), drbd (8.2.6), freetype (2.3. 7), gdb (6.8), gnupg (1.4.9), iptables (1.4.1.1), kernel (2.6.26), kvm (71), libpng (1.2.29), m4 (1.4.11), mailman ( 2.1.11), mod_perl (2.0.4), mrtg (2.16.2), nagios (3.0.3), nagios plugins (1.4.12), net-snmp (5.4.1.2), openldap (2.4.10) , openssh (5.0p1), openssl (0.9.8h), openswan (2.6.14), php5 (5.2.6), postfix (2.5.2, postgresql (8.2.9), rsync (3.0.3), samba ( 3.2.0), spamassassin (3.2.5), squid (3.0.STABLE7), sudo (1.6.9p17), syslog-ng (2.0.9), vim (7.1.330), xl2tpd (1.2.0), and zaptel (1.4.11)

All new users downloading EnGarde Secure Linux for the first time or users who use the LiveCD environment should download this release. Users who are currently using EnGarde Secure Linux do not need to download this release — they can update their machines via the Guardian Digital Secure Network WebTool module.

Version number 3.0.20
Release status Final
Operating systems Linux
Website Guardian Digital
Download
License type GPL