Firmware update: OpenWrt 15.05 rc1

OpenWrt is an alternative open source firmware for a large number various routers and embedded devices. By means of the opkg package management system there is the possibility to determine for yourself what the router can and cannot do. Some people are also actively working on this on GoT, for example for the TP-Link TL-WR1043ND. After a lot of tinkering, the development has released the first release candidate of version 15.05, which has been given the nickname Chaos Calmer. Below are the release notes for this release.

Highlights since Barrier Breaker

  • Linux kernel updated to version 3.18

Improved Security Features

  • Rewritten package signing architecture based on ed25519
  • Added support for jails
  • Added support for hardened builds

Improved Networking Support

  • Added or improved support for lots of 3G/4G modems (MBIM, QMI, NCM, …)
  • Added support for 464XLAT (CLAT) [RFC 6877 + RFC 7050]
  • Netfilter performance enhancements (conntrack route cache)
  • Improved support for self-managing networks [draft-ietf-homenet-hncp]
  • Better multi-core support for the network stack
  • Improved support for MAP-E and MAP-T IPv4 transitioning technologies [draft-ietf-softwire-map, -map-t, -map-dhcp]
  • Improved network auto-setup capable of detecting and bootstrapping IPv4-only, 6rd, Dual-Stack, IPv6-only, DS-Lite, LW4over6, MAP-E, MAP-T, 464XLAT and combinations without explicit configuration [based on RFC 7084]
  • Added support for Smart Queue Management (SQM) QoS, AQM and Traffic Shaping
  • Improved support for DNSSEC

Platform and Driver Support

  • Added support for feeds of externally maintained targets
  • New mt7621 subtarget for Mediatek 11ac SoC
  • New mt76 mac80211 based wifi driver for MTK 11ac cores.
  • New mwlwifi mac80211 based wifi driver for the Marvell 88W8864
  • New bcm53xx target for Broadcom ARM BCM47xx/53xx devices
  • brcm2708: support for Raspberry Pi 2
  • brcm63xx: support for BCM6318 and BCM63268 family
  • brcm63xx: improved fallback sprom support with bcma support

Known Issues

  • libusb-1.0 is currently not installable (#19668). This is already fixed in svn. This can be manually fixed by applying the changes from r45702 by hand.
  • the targets feed is part of opkg.conf, and will produce warnings. It is safe to remove from /etc/opkg.conf.

Version number 15.05 rc1
Release status beta
Website OpenWrt
Download
License type GPL